doesn't support vc2005

Would you please add support for VC2005?

Id #1806 | Release: None | Updated: Nov 3, 2013 at 4:57 AM by impishian | Created: Nov 3, 2013 at 4:57 AM by impishian

doesn't support vc2005

Would you please add support for VC2005?

Id #1805 | Release: None | Updated: Nov 3, 2013 at 4:57 AM by impishian | Created: Nov 3, 2013 at 4:57 AM by impishian

The tests are run in the wrong working directory

The test runner does not take into account the working directory specified in the Debug settings.

Id #1619 | Release: None | Updated: Jun 12, 2013 at 6:53 AM by burbelgruff | Created: Jun 12, 2013 at 6:49 AM by burbelgruff

The unit test results are not asyncronously updating the output window

When running a large unit test project, the output window is empty until the unit test has completed. The actual running of the test should be done in a separate thread to avoid this problem.

Id #1618 | Release: None | Updated: Jun 12, 2013 at 6:46 AM by burbelgruff | Created: Jun 12, 2013 at 6:46 AM by burbelgruff

The test runner crashes when running with a large numer of tests

There is an error in the function StartTest, where synchronous and asynchronous stream operations are mixed: process.BeginOutputReadLine( ); //Begin asynchronous read //Remove this line to make th...

Id #1617 | Release: None | Updated: Jun 12, 2013 at 6:42 AM by burbelgruff | Created: Jun 12, 2013 at 6:42 AM by burbelgruff

Test launching uses Win32 configuration even if x64 is the current platform

I have a project with Win32 and x64 configurations. Test launching (all varieties) was failing with a message about unable to find the specified path   It turned out I had changed the output path ...

Id #1328 | Release: None | Updated: Jun 17, 2014 at 7:50 PM by erichkeane | Created: Sep 17, 2012 at 2:32 AM by mellowpellow

Running with the toolbar changes the working directory

I am using VS 2010, and trying to read files using relative paths like so:   FIleReader::Read ("Configuration\somefile.dat");   If I run the gtest program directly, this works fine, as the current ...

Id #1290 | Release: None | Updated: Oct 24, 2013 at 1:39 PM by sakthiyuvaraj | Created: Aug 1, 2012 at 11:24 PM by rlabbe

Wrong version in GoogleTestAddIn.AddIn for Visual Studio 2008

<Version> should be 9.0, not 10.0

Id #1258 | Release: None | Updated: Jun 14, 2013 at 6:53 AM by Ovaron95 | Created: Jun 20, 2012 at 10:23 AM by knatten

Execution of test does not work when name of the test contains "TEST" or "TEST_F"

Execution of test does not work when name of the test contains "TEST" or "TEST_F" because there is a fault in the rocognition of the selected line.

Id #1235 | Release: None | Updated: Jun 14, 2013 at 6:53 AM by Ovaron95 | Created: May 18, 2012 at 1:02 PM by Ovaron95

After debugging a selected test function, only this function could be started by run all tests.

If you can execute only one test after you debugged a selected test function, then at the Command Arguments there is set the filter argument for googletest.   This fault in the addin appears when ...

Id #1234 | Release: GoogleTestAddin | Updated: Jun 14, 2013 at 6:53 AM by Ovaron95 | Created: May 16, 2012 at 6:49 PM by Ovaron95